10/20/25 AWS Outage Impacting TalkingPoints Features

Incident Report for TalkingPoints

Resolved

TalkingPoints has confirmed that all functionality has returned to normal, and any overnight syncs impacted by the AWS outage were successfully completed overnight. If you have any further questions or concerns, please contact support@talkingpts.org.
Posted Oct 21, 2025 - 07:50 PDT

Monitoring

TalkingPoints continues to monitor the global AWS outage, and as of 4:40 PM EDT / 1:40 PM PDT, some SIS data has begun to sync again as portions of the AWS outage are resolved. We expect functionality to return over the next several hours, and we will confirm once the outage is fully resolved.
Posted Oct 20, 2025 - 14:29 PDT

Update

TalkingPoints continues to monitor the global AWS outage.
As of 2PM EDT / 11 AM PDT, all translation delays were resolved, and in-app translation has been functioning without disruption.

However, the AWS outage continues to impact data syncing from multiple Student Information Systems. Please note that some data in TalkingPoints may not be updated until the AWS outage is resolved.
Posted Oct 20, 2025 - 12:03 PDT

Update

TalkingPoints continues to monitor the global AWS outage, which is directly impacting multiple TalkingPoints features including translation and attendance.
Due to this outage, some messages that should have been translated have been delivered in their original language.
Posted Oct 20, 2025 - 10:27 PDT

Identified

TalkingPoints is monitoring the global AWS outage, which is directly impacting multiple TalkingPoints modules. Please note that some data in TalkingPoints may not be updated until the AWS outage is resolved.
Posted Oct 20, 2025 - 08:25 PDT
This incident affected: Web Product and Mobile Product.