TalkingPoints support unavailable: 3rd party communication tool is down

Incident Report for TalkingPoints

Resolved

Intercom, the third-party communication application, has marked this issue has resolved. All support operations have resumed. Again, TalkingPoints remains fully operational and unaffected. Questions? Please reach out to partnersupport@talkingpts.org
Posted Jan 09, 2026 - 15:53 PST

Update

We are continuing to monitor for any further issues.
Posted Jan 09, 2026 - 15:52 PST

Monitoring

The third-part application, Intercom, has implemented a fix, and the application is again available. Intercom is currently monitoring this fix. Again, TalkingPoints remains fully operational and unaffected. The Support Team is resuming replies to end user inquiries. Questions? Please reach out to partnersupport@talkingpts.org
Posted Jan 09, 2026 - 12:59 PST

Update

We are continuing to investigate this issue.
Posted Jan 09, 2026 - 12:56 PST

Investigating

TalkingPoints support is currently unavailable because Intercom, the third-party application used to answer questions from end users, is not functioning as expected. Please note that TalkingPoints remains fully operational and unaffected. We sincerely apologize for this inconvenience and will provide updates as we have them.
Posted Jan 09, 2026 - 12:17 PST
This incident affected: Web Product and Mobile Product.