Inconsistencies with language display for polls sent out by teachers
Incident Report for TalkingPoints
Resolved
This incident has been resolved.
Posted Mar 28, 2024 - 11:34 PDT
Identified
TalkingPoints has identified minor inconsistencies with language display for polls sent out by teachers on our web and mobile app. We apologize for this inconvenience and assure you that our team is working to fix the issue as quickly as possible. Questions? Contact us at support@talkingpts.org
Posted Mar 27, 2024 - 14:19 PDT
This incident affected: Web Product and Mobile Product.