Inconsistent email notification delivery

Incident Report for TalkingPoints

Resolved

TalkingPoints is releasing a fix for email notifications. Email notifications for any message received since Friday, October 10th at 7pm ET/4pm PT will be delivered as part of this fix.
Questions? Contact us at support@talkingpts.org
Posted Oct 11, 2025 - 08:33 PDT

Identified

TalkingPoints is currently experiencing issues with email notifications. We apologize for this inconvenience and assure you that our team has identified the issue. We are working to release a fix shortly. Questions? Contact us at support@talkingpts.org
Posted Oct 10, 2025 - 15:52 PDT
This incident affected: Web Product and Mobile Product.