The issue with teacher email notification has been resolved. We want to again emphasize this issue only affected email notifications — all messaging between teachers, staff, and families continue to be delivered without disruption.
A fix has been implemented for the issue affecting teacher email notifications. We want to emphasize this issue only affected email notifications — all messaging between teachers, staff, and families has continued to be delivered without disruption. There has been no impact on the ability to send or receive messages on the TalkingPoints platform.
Our team is currently monitoring the effects of this fix. If you have any questions, please reach out to us at support@talkingpts.org
Posted Oct 13, 2025 - 16:37 PDT
Identified
TalkingPoints is currently experiencing issues with teacher email notifications. We apologize for this inconvenience and assure you that our team has identified the issue. We are working to release a fix shortly. Questions? Contact us at support@talkingpts.org
Posted Oct 13, 2025 - 14:27 PDT
This incident affected: Web Product and Mobile Product.