Issue Toggling Between School and Teacher Mode

Incident Report for TalkingPoints

Resolved

This incident has been resolved.
Posted Dec 11, 2025 - 11:35 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 11, 2025 - 10:46 PST

Identified

TalkingPoints is currently experiencing an issue where some users are unable to toggle between school and teacher mode within the product. We apologize for this inconvenience and assure you that our team is working to identify and resolve the issue as quickly as possible.

Questions? Contact us at support@talkingpts.org
Posted Dec 11, 2025 - 10:10 PST
This incident affected: Web Product.